Installing R Shiny on Linux

After opening and making free some data i wanted to visualize it with R Shiny.  But i had to manage with some errors, here i share the errors and how i fixed them. First, i need the rsconnect package, but i get this error message:

package ‘rsconnect’ is not available (for R version 3.1.1)

So i will do it from scratch:

wget https://cran.r-project.org/src/contrib/RCurl_1.95-4.8.tar.gz
wget https://cran.r-project.org/src/contrib/rsconnect_0.8.tar.gz
wget https://cran.r-project.org/src/contrib/PKI_0.1-3.tar.gz
wget https://cran.r-project.org/src/contrib/base64enc_0.1-3.tar.gz
wget https://cran.r-project.org/src/contrib/RCurl_1.95-4.8.tar.gz
wget https://cran.r-project.org/src/contrib/bitops_1.0-6.tar.gz
wget https://cran.r-project.org/src/contrib/RJSONIO_1.3-0.tar.gz
wget https://cran.r-project.org/src/contrib/yaml_2.1.14.tar.gz
wget https://cran.r-project.org/src/contrib/rstudioapi_0.6.tar.gz

Installing the packages:

R CMD INSTALL RCurl_1.95-4.8.tar.gz
R CMD INSTALL base64enc_0.1-3.tar.gz
R CMD INSTALL PKI_0.1-3.tar.gz
R CMD INSTALL bitops_1.0-6.tar.gz
R CMD INSTALL RJSONIO_1.3-0.tar.gz
R CMD INSTALL packrat_0.4.8-1.tar.gz
R CMD INSTALL yaml_2.1.14.tar.gz 
R CMD INSTALL rstudioapi_0.6.tar.gz
R CMD INSTALL rsconnect_0.8.tar.gz

Here you may get this error:

pki.h:11:25: fatal error: openssl/err.h: No such file or directory
 #include <openssl/err.h>

Solution:

apt-get install libssl-dev